ページの本文へ

BoxCore構成

  • マスタスイッチ(L3機能あり)が2台、複数のリングを管理する構成
  • L2の冗長にはMMRP-Plus、L3の冗長にはVRRPを使用
  • マスタスイッチ(L3機能あり)同士の接続にはLAGを使用
  • MMRP-PlusのVlan分散機能を使用し、Vlan20, 40のブロッキングポートをAP1側に設定(他のVlanのブロッキングポートはAP2側)

【VLAN情報】
v10: ユーザーVlan(AP3,4)
v20: ユーザーVlan(AP3,4)
v40: ユーザーVlan(AP5)
v100: スイッチ管理用Vlan
v101: MMRP制御用Vlan(Ring1)
v102: MMRP制御用Vlan(Ring2)

【MMRP-Status】
Master Vlan: v10, v30, v100-102
Slave Vlan: v20, v40

Boxcore構成

リングスイッチの設定

リングスイッチの設定(AP1)
AEOS7設定例 コメント
AP1(分散マスタスイッチ)の基本設定
hostname AP1 ホスト名の設定
vlan database
 vlan 10 name v10
 vlan 20 name v20
 vlan 30 name v30
 vlan 40 name v40
 vlan 100 name kanri-sw
 vlan 101 name kanri-1
 vlan 102 name kanri-2
VLANの設定
・ユーザーVLAN名: “v10”, “v20“,“v30”,“v40”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-1”,“kanri-2”
interface port 1
 switchport mode trunk
 switchport trunk add 10,20,100,101
物理インタフェース(port 1:Ring1に所属)の設定
・ユーザー/スイッチ管理用VLANとMMRP-Plus制御用VlanをTagでアサイン
※MMRP-Plusを使用するポートではTagの設定が必須
interface port 2
switchport mode trunk
switchport trunk add 30,40,100,102
物理インタフェース(port 2:Ring2に所属)の設定
・ユーザー/スイッチ管理用VlanとMMRP-Plus制御用VlanをTagでアサイン
※MMRP-Plusを使用するポートではTagの設定が必須
interface port 43-44
 switchport mode trunk
 switchport trunk add 10,20,30,40,100
 media utp
 utp advertise delete 10m-speed
 utp advertise delete 100m-speed
 link-aggregation 1
物理インタフェース(port 43-44)の設定
・ユーザー/スイッチ管理用VlanをTagでアサイン
※本ポートではMMRP-Plusが動作しないので、MMRP-Plus制御用VLANをアサインする必要はありません。
・メディアタイプをUTPに設定(UTP/SFPコンボポートのみ必要)
・オートネゴの速度を1000/fullのみに設定
※LAG接続を使用するポートでは通信速度の統一が必須
・LAG接続(Static)を設定
interface vlan <VLAN ID>
 ip address 192.168.<VLAN ID>.254/24
VLANインターフェースの設定
・<VLAN ID>=10,20,30,40,100の計5つのVLANのIPアドレスを192.168.<VLAN ID>.254/24に設定
 AP1(分散マスタスイッチ)のMMRP-Plus設定
mmrp-plus vlangroup 1 slave-vid 20,40 MMRP-PlusのVLANグループ設定
※VLANグループごとにブロッキングポートを分けるための設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 vlangroup 1
mmrp-plus ring 1 divided-master master-port 1
mmrp-plus ring 1 fdb-flush-timer 0
MMRP-Plus(Ring1)の設定
・制御用VlanをVlan101、VLANグループを1、Masterポートをport 1に設定
・FDB未学習時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 vlangroup 1
mmrp-plus ring 2 divided-master master-port 2
mmrp-plus ring 2 fdb-flush-timer 0
MMRP-Plus(Ring2)の設定
・制御用VlanをVlan102、VLANグループを1、Masterポートをport 2に設定
・FDB学習停止時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AP1(分散マスタスイッチ)のVRRP設定
router vrrp <VRID>
 virtual-ip 192.168.<VLAN ID>.254 master
 interface vlan <VLAN ID>
 enable
VRRPの設定
<VLAN ID>=10,20,30,40,100の計5つのVLANに対応するVirtual Router(Master)を<VRID>=<VLAN ID>として作成する。
ip icmp redirect send disable ICMPリダイレクトメッセージの送信の無効化
※VRRPを使用する場合の推奨設定
AEOS8設定例 コメント
AP1(分散マスタスイッチ)の基本設定
hostname AP1 ホスト名の設定
vlan database
 vlan 10 name v10
 vlan 20 name v20
 vlan 30 name v30
 vlan 40 name v40
 vlan 100 name kanri-sw
 vlan 101 name kanri-1
 vlan 102 name kanri-2
VLANの設定
・ユーザーVLAN名: “v10”,“v20”,“v30”,“v40”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-1”,“kanri-2”
interface port 1/1
 switchport mode trunk
 switchport trunk add 10,20,100,101
物理インタフェース(port 1:Ring1に所属)の設定
・ユーザー/スイッチ管理用VLANとMMRP-Plus制御用VlanをTagでアサイン
※MMRP-Plusを使用するポートではTagの設定が必須
interface port 1/2
 switchport mode trunk
 switchport trunk add 30,40,100,102
物理インタフェース(port 2:Ring2に所属)の設定
・ユーザー/スイッチ管理用VlanとMMRP-Plus制御用VlanをTagでアサイン
※MMRP-Plusを使用するポートではTagの設定が必須
interface lag 1
 switchport mode trunk
 switchport trunk add 10,20,30,40,100
interface port 1/43-44
 link-aggregation 1
物理インタフェース(port 43-44)の設定
・ユーザー/スイッチ管理用VlanをTagでアサイン
※本ポートではMMRP-Plusが動作しないので、MMRP-Plus制御用VLANをアサインする必要はありません。
・メディアタイプをUTPに設定(UTP/SFPコンボポートのみ必要)
※LAG接続を使用するポートでは通信速度の統一が必須
・LAG接続(Static)を設定
interface vlan <VLAN ID>
 ip address 192.168.<VLAN ID>.254/24
VLANインターフェースの設定
・<VLAN ID>=10,20,30,40,100の計5つのユーザーVlanのIPアドレスを192.168.<VLAN ID>.254/24に設定
AP1(分散マスタスイッチ)のMMRP-Plus設定
mmrp-plus vlangroup 1 slave-vid 20,40 MMRP-PlusのVLANグループ設定
※VLANグループごとにブロッキングポートを分けるための設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 vlangroup 1
mmrp-plus ring 1 divided-master port 1/1
mmrp-plus ring 1 fdb-flush timer 0
mmrp-plus ring 1 fdb-flush all
MMRP-Plus(Ring1)の設定
・制御用VlanをVlan101、VLANグループを1、Masterポートをport 1に設定
・FDB未学習時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 vlangroup 1
mmrp-plus ring 2 divided-master port 1/2
mmrp-plus ring 2 fdb-flush timer 0
mmrp-plus ring 2 fdb-flush all
MMRP-Plus(Ring2)の設定
・制御用VlanをVlan102、VLANグループを1、Masterポートをport 2に設定 ・FDB学習停止時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AP1(分散マスタスイッチ)のVRRP設定
router vrrp <VRID> vlan <VLAN ID>
 virtual-ip 192.168.<VLAN ID>.254 master
 accept-mode enable
enable
VRRPの設定
<VLAN ID>=10,20,30,40,100の計5つのユーザーVLANに対応する Virtual Router(Master)を<VRID>=<VLAN ID>として作成する。
ip icmp redirect send disable ICMPリダイレクトメッセージの送信の無効化
※VRRPを使用する場合の推奨設定
リングスイッチの設定(AP2)
AEOS7設定例 コメント
AP2(分散シャドウスイッチ)の基本設定
※以下の下線部分(ホスト名、VLANインターフェースのIPアドレス)のみAP1の基本設定と異なり、他は全て同じ設定となります。
hostname AP2 ホスト名の設定
interface vlan <VLAN ID>
ip address 192.168.<VLAN ID>.253/24
VLANインターフェースの設定
・<VLAN ID>=10,20,30,40,100の計5つのVLANのIPアドレスを192.168.<VLAN ID>.253/24に設定
AP2(分散シャドウスイッチ)のMMRP-Plus設定※
mmrp-plus vlangroup 1 slave-vid 20,40 MMRP-PlusのVLANグループ設定
※VLANグループごとにブロッキングポートを分けるための設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 vlangroup 1
mmrp-plus ring 1 divided-shadow slave-port 1
mmrp-plus ring 1 fdb-flush-timer 0
MMRP-Plus(Ring1)の設定
・制御用VlanをVlan101、VLANグループを1、Slaveポートをport 1に設定
・FDB未学習時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 vlangroup 1
mmrp-plus ring 2 divided-shadow slave-port 2
mmrp-plus ring 2 fdb-flush-timer 0
MMRP-Plus(Ring2)の設定
・制御用VlanをVlan102、VLANグループを1、Slaveポートをport 2に設定
・FDB学習停止時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AP2(分散シャドウスイッチ)のVRRP設定※
router vrrp <VRID>
 virtual-ip 192.168.<VLAN ID>.254 backup
 interface vlan <VLAN ID>
 enable
VRRPの設定
<VLAN ID>=10,20,30,40,100の計5つのVLANに対応するVirtual Router(Backup)を<VRID>=<VLAN ID>として作成する。
ip icmp redirect send disable ICMPリダイレクトメッセージの送信の無効化
※VRRPを使用する場合の推奨設定
AEOS8設定例 コメント
AP2(分散シャドウスイッチ)の基本設定
※以下の下線部分(ホスト名、VLANインターフェースのIPアドレス)のみAP1の基本設定と異なります。
hostname AP2 ホスト名の設定
interface vlan <VLAN ID>
 ip address 192.168.<VLAN ID>.253/24
VLANインターフェースの設定
・<VLAN ID>=10,20,30,40,100の計5つのVLANのIPアドレスを192.168.<VLAN ID>.253/24に設定
AP2(分散シャドウスイッチ)のMMRP-Plus設定※
※以下の下線部分(MMRP-Plusポート設定)のみAP1と異なります。
mmrp-plus vlangroup 1 slave-vid 20,40 MMRP-PlusのVLANグループ設定
※VLANグループごとにブロッキングポートを分けるための設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 vlangroup 1
mmrp-plus ring 1 divided-slave port 1/1
mmrp-plus ring 1 fdb-flush timer 0
mmrp-plus ring 1 fdb-flush all
MMRP-Plus(Ring1)の設定
・制御用VlanをVlan101、VLANグループを1、Slaveポートをport 1に設定
・FDB未学習時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 vlangroup 1
mmrp-plus ring 2 divided-slave port 1/2
mmrp-plus ring 2 fdb-flush timer 0
mmrp-plus ring 2 fdb-flush all
MMRP-Plus(Ring2)の設定
・制御用VlanをVlan102、VLANグループを1、Slaveポートをport 2に設定
・FDB学習停止時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AP2(分散シャドウスイッチ)のVRRP設定※
※以下の下線部分(VRRPバックアップ設定)のみAP1と異なります。
router vrrp <VRID> vlan <VRID>
 virtual-ip 192.168.<VLAN ID>.254 backup
 accept-mode enable
 enable
VRRPの設定
<VLAN ID>=10,20,30,40,100の計5つのVLANに対応する Virtual Router(Backup)を<VRID>=<VLAN ID>として作成する。
ip icmp redirect send disable ICMPリダイレクトメッセージの送信の無効化
※VRRPを使用する場合の推奨設定

※ 下線部分はAP1の設定と異なる箇所を示しています。

リングスイッチの設定(AP3~4)
AEOS7設定例 コメント
AP3~4(Ring1アウェアスイッチ)の設定
※以下の下線部分(ホスト名、VLANインターフェースのIPアドレス)のみAP3とAP4で設定が異なり、他は全て同じ設定となります。
hostname AP3 ホスト名の設定
vlan database
 vlan 10 name v10
 vlan 20 name v20
 vlan 100 name kanri-sw
 vlan 101 name kanri-1
VLANの設定
・ユーザーVLAN名: “v10”,“v20”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-1”
interface port 1-12
 switchport access vlan 10
物理インタフェース(port 1-12)の設定
・ユーザーVlan“v10”をアサイン
interface port 13-22
 switchport access vlan 20
物理インタフェース(port 13-22)の設定
・ユーザーVlan“v20”をアサイン
interface port 23-24
 switchport mode trunk
 switchport trunk add 10,20,100,101
物理インタフェース(port 23-24)の設定
・ユーザー/スイッチ管理用Vlanと制御用VlanをTagでアサイン
interface vlan 100
 ip address 192.168.100.3/24
VLANインタフェース(Vlan100)の設定
・Vlan100に管理用のIPアドレスを設定
ip route 0.0.0.0/0 192.168.100.254 デフォルトゲートウェイの設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 aware port 23 port 24
mmrp-plus ring 1 fdb-flush-timer 0
MMRP-Plus(Ring1)の設定(アウェアの場合)
・制御VlanをVlan101、アウェアポートをPort23,24に設定
・FDB学習停止時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AEOS8設定例 コメント
AP3~4(Ring1アウェアスイッチ)の設定
※以下の下線部分(ホスト名、VLANインターフェースのIPアドレス)のみAP3とAP4で設定が異なり、他は全て同じ設定となります。
hostname AP3 ホスト名の設定
vlan database
 vlan 10 name v10
 vlan 20 name v20
 vlan 100 name kanri-sw
 vlan 101 name kanri-1
VLANの設定
・ユーザーVLAN名: “v10”,“v20”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-1”
interface port 1/1-12
 switchport mode access
 switchport access vlan 10
物理インタフェース(port 1-12)の設定
・ユーザーVlan“v10”をアサイン
interface port 1/13-22
 switchport mode access
 switchport access vlan 20
物理インタフェース(port 13-22)の設定
・ユーザーVlan“v20”をアサイン
interface port 1/23-24
 switchport mode trunk
 switchport trunk add 10,20,100,101
物理インタフェース(port 23-24)の設定
・ユーザー/スイッチ管理用Vlanと制御用VlanをTagでアサイン
interface vlan 100
 ip address 192.168.100.3/24
VLANインタフェース(Vlan100)の設定
・Vlan100に管理用のIPアドレスを設定
ip route 0.0.0.0/0 192.168.100.254 デフォルトゲートウェイの設定
mmrp-plus ring 1 vid 101
mmrp-plus ring 1 aware port 1/23 port 1/24
mmrp-plus ring 1 fdb-flush timer 0
mmrp-plus ring 1 fdb-flush all
MMRP-Plus(Ring1)の設定(アウェアの場合)
・制御VlanをVlan101、アウェアポートをPort23,24に設定
・FDB学習停止時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
リングスイッチの設定(AP5)
AEOS7設定例 コメント
AP5(Ring2アウェアスイッチ)の設定
hostname AP5 ホスト名の設定
vlan database
 vlan 30 name v30
 vlan 40 name v40
 vlan 100 name kanri-sw
 vlan 102 name kanri-2
VLANの設定
・ユーザーVLAN名: “v30”,“v40”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-2”
interface port 1-12
 switchport access vlan 30
物理インタフェース(port 1-12)の設定
・ユーザーVlan“v30”をアサイン
interface port 13-22
 switchport access vlan 40
物理インタフェース(port 13-22)の設定
・ユーザーVlan“v40”をアサイン
interface port 23-24
 switchport mode trunk
 switchport trunk add 30,40,100,102
物理インタフェース(port 23-24)の設定
・ユーザー/スイッチ管理用Vlanと制御用VlanをTagでアサイン
interface vlan 100
 ip address 192.168.100.5/24
VLANインタフェース(Vlan100)の設定
・Vlan100に管理用のIPアドレスを設定
ip route 0.0.0.0/0 192.168.100.254 デフォルトゲートウェイの設定
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 aware port 23 port 24
mmrp-plus ring 2 fdb-flush-timer 0
MMRP-Plus(Ring2)の設定(アウェアの場合)
・制御VlanをVlan102、アウェアポートをPort23,24に設定
・FDB学習停止時間を0秒に設定(デフォルト5秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定
AEOS8設定例 コメント
AP5(Ring2アウェアスイッチ)の設定
hostname AP5 ホスト名の設定
vlan database
 vlan 30 name v30
 vlan 40 name v40
 vlan 100 name kanri-sw
 vlan 102 name kanri-2
VLANの設定
・ユーザーVLAN名: “v30”,“v40”
・スイッチ管理用VLAN名: “kanri-sw”
・MMRP-Plus制御用VLAN名: “kanri-2”
interface port 1/1-12
 switchport mode access
 switchport access vlan 30
物理インタフェース(port 1-12)の設定
・ユーザーVlan“v30”をアサイン
interface port 1/13-22
 switchport mode access
 switchport access vlan 40
物理インタフェース(port 13-22)の設定
・ユーザーVlan“v40”をアサイン
interface port 1/23-24
 switchport mode trunk
 switchport trunk add 30,40,100,102
物理インタフェース(port 23-24)の設定
・ユーザー/スイッチ管理用Vlanと制御用VlanをTagでアサイン
interface vlan 100
 ip address 192.168.100.5/24
VLANインタフェース(Vlan100)の設定
・Vlan100に管理用のIPアドレスを設定
ip route 0.0.0.0/0 192.168.100.254 デフォルトゲートウェイの設定
mmrp-plus ring 2 vid 102
mmrp-plus ring 2 aware port 1/23 port 1/24
mmrp-plus ring 2 fdb-flush timer 0
mmrp-plus ring 2 fdb-flush all
MMRP-Plus(Ring2)の設定(アウェアの場合)
・制御VlanをVlan102、アウェアポートをPort23,24に設定
・FDB学習停止時間を0秒に設定(デフォルト1秒)
※MMRP-PlusとL3中継を併用する場合の推奨設定
・FDBフラッシュ対象を全ポートにする
mmrp-plus enable MMRP-Plusの有効化
qos enable QoSの有効化
※MMRP-Plus制御フレームを優先制御するための設定

設定のポイント

ポートへのTag設定

  • MMRP-Plusを使用するポートはTag設定が必須です。ポートへVlanを指定する際、ユーザーーVlan以外に後述のMMRP-Plus制御用Vlanの指定も必要です。

MMRP-Plus制御用フレーム

  • 本設定例ではVlan101,Vlan102をMMRP-Plus制御用Vlanに使用しています。MMRP制御用Vlanはリングごとに分けていただくことを推奨しています。デフォルトではVlan1が制御用Vlanに指定されています。
    (Vlan1を制御用Vlanに使用する場合、“mmrp-plus ring 1 vid ”の設定は不要ですが、Vlan100の代わりにVlan1をリング内に追加してください)

QoS設定

  • MMRP-Plus制御フレームを優先処理するために設定。qos enableのみの設定でMMRP-Plus制御フレームが優先的に処理されます。

Vlan分散について

  • Slave-Vlanの設定は、マスタ/シャドゥスイッチで必ず一致させてください。
  • Slave-Vlanに指定できるVlan個数に制限はありません。
  • 設定可能なVlanグループは最大8つです。(機種によっては6つ)

アウェアスイッチの設定

  • Vlan分散を行う場合でもアウェアスイッチには特別な設定追加は不要です。

FDBフラッシュ動作

  • MMRP-Plus切替発生時、AEOS7では全FDBをフラッシュしますが、AEOS8のデフォルト動作ではMMRP-Plusが動作するポートで学習したFDBのみをフラッシュします。AEOS8をAEOS7と同様の動作とするためには「mmrp-plus ring <リングID> fdb-flush all」と設定します。AEOS8ではAEOS7との互換性を保つ等の目的で本設定を推奨しています。

MMRP-PlusとL3中継機能を併用する場合の注意点

  • MMRP-Plus切替発生直後のFDB学習停止時間(FDBフラッシュタイマー:AEOS7:デフォルト5秒、AEOS8:デフォルト1秒)は0秒に設定していただくことを推奨します。
    ※FDB学習停止時間内でL3中継のパフォーマンスが低下し、機器障害時の切替速度が遅延する場合があるため。本パラメータを0秒として頂ければそのような現象は発生しません。
  • 本パラメータの設定値は全機器で共通の値としていただく必要があります。
  • 本パラメータのデフォルト値は将来的に0秒に変更される予定です。(時期未定)

BoxCore構成(MMRP-Plusのマルチリング構成)

  • 1台のスイッチで最大1000リング、実質的にはスイッチの搭載ポート数分のリング(Ap13000-48Xの場合は48リング)まで必要に応じてリングを増やしていただくことが可能です。またMMRP-Plusプロトコルフレームはハードウェア処理されますので、スイッチの搭載ポート数分までリングを増やして頂いても、スイッチのCPU負荷は動作安定性に関わるほど増加はしませんのでご安心ください。
  • 1つのリング内に増設可能なアウェアスイッチの台数に制限はありません。
ページの先頭へ